Monday, November 21, 2005

Installing ALSA in debian sarge 2.6.8-2-386

Install alsa-base (apt-get install alsa-base) and alsa-utils (apt-get install alsa-utils).
Make sure you're part of the "audio" group for this edit /etc/group file as
audio:*:29:username
if the above line is not there.

Run $/sbin/modprobe snd-emu10k1 ; if it doesn't work try with snd-emu10k2 OR snd-ca0106
Now run $alsaconf ; this is an alsa configurator and detects the sound card and configure it.


srd24:~# alsaconf
Unloading ALSA sound driver modules: snd-emu10k1-synth snd-emux-synth snd-seq-v irmidi snd-seq-midi-emul snd-seq-oss snd-seq-midi snd-seq-midi-event snd-seq sn d-emu10k1 snd-util-mem snd-hwdep snd-intel8x0 snd-ac97-codec snd-pcm-oss snd-mi xer-oss snd-pcm snd-timer snd-page-alloc snd-mpu401-uart snd-rawmidi snd-seq-de vice.
Building card database...


Running update-modules...
Loading driver...
Setting up ALSA....
Setting default volumes...
Saving the mixer setup used for this in /var/lib/alsa/asound.state.


===============

Now ALSA is ready to use.
For adjustment of volumes, use your favorite mixer.

Have a lot of fun!


Here are the choices:
intel8x0 Intel Corp. 82801AA AC'97 Audio (rev 02)
legacy probe legacy ISA (non-PnP) chips

I select the intel card and pressed enter. Now I get this:
Configuring snd-intel8x0
Do you want to modify /etc/modprob.d/sound
(And /etc/modprobe.conf if present)?


I select 'yes' and press enter.
"OK, sound driver is configured.
ALSA CONFIGURATOR
will prepare the card for playing now.
Now I will load the ALSA sound driver and use amixer to raise the default sound volumes.
You can change the volume later via a mixer.


I select and press ok.

Running update-modules...
Loading Driver...
Setting up ALSA...
Setting default volumes...

===

Now ALSA is ready to use
For adjustment of volumes, use your favorite mixer.

Have a lot of fun!
---------------------------------------
---------------------------------------

Finally, alsamixer and volume control is working otherwise it was giving error as
$alsamixer
alsamixer: function snd_ctl_open failed for default: No such device
and when volume control is selected it is giving error as
no volume control elements and/or devices found.

1 comment:

Raimundo Santos said...

I'm getting this error message:

rtc:/home/raitech# alsamixer

alsamixer: function snd_ctl_open failed for default: No such device

rtc:/home/raitech#

what might be hapenning? This error - or a simillar - I'm gettng on XMMS, also only with OSS drivers.

with you could, anwser me on raitech email on the gmail.com .

Sorry about my english, I know it's so poor... ;-) (I am brazillian)